A fix has been implemented and we are monitoring the results.
Posted Dec 03, 2025 - 18:21 UTC
Investigating
Customers are being presented with a generic error "Error: Cannot send electronic claim. Error submitting claim (s). Please contact TheraNest Support at support@theranest.com for more information."
Posted Dec 03, 2025 - 18:03 UTC
This incident affected: Ensora Clearinghouse (Apex) and Ensora eRx.